1
Vote

Fields Explorer

description

Field Explorer keeps crashing on me when I try to generate the any files form any SharePoint artifcats. It seems there is a reference to a dll which I do not have.
 
The following is the error I am getting:
System.TypeInitializationException: The type initializer for 'Imtech.SharePoint.Utils.FieldsExplorer.Extensions' threw an exception. ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.
File name: 'Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'
at Imtech.SharePoint.Utils.FieldsExplorer.Extensions..cctor()
 
What are the system requirements for the tool?
I am currently using the latest WSS VPC from Microsoft. Do I need MOSS components to use the tool?

comments

WaldekMastykarz wrote Apr 29, 2009 at 9:48 PM

Microsoft.SharePoint.Publishing is an assembly shipped with MOSS 2007. Some things that Imtech Fields Explorer generates (like Page Layouts for instance) are MOSS 2007 only, so yes, you have to have MOSS 2007 installed to use it.

wrote Feb 14, 2013 at 8:41 PM