ECQWP works in full trust web sites

Apr 20, 2009 at 5:25 PM
This is a very nice webpart that fills the gap left in the default CQWP.

However, in order to get it to work, you need to run it in full trust mode.
The first time I tried this webpart, I added the solution, deployed it, and then I could not find it anywhere when I tried to add it to a webpart zone.

What happened is that to run the ECQWP you need to be running the website in full trust. I was running it in minimal trust.
What was very strange and confusing was that I could add a ECQWP Pager, but the ECQWP was nowhere to be found.

While trying to solve the problem, I found out that ECWQP can have 3 different behaviors:

- If you use minimal trust, ECWQP does not even show up in the available webparts (you only see the the ECWQP Pager).
- If you use medium trust, you can add the ECWQP but it will not return any values (you get the default message saying that the webpart has no results to show).
- If you use full trust, ECWQP works like a charm.

Since it is a peculiar behaviour, it wanted to share it, so that it saves some headaches to the next guy that tries it out.
Oct 20, 2010 at 3:09 AM

Maybe too late for als but I have rebuilt the solution so that it deploys to the GAC.

You have two options:

  • Simply modify the manifest.xml file in source and change DeploymentTarget="GlobalAssemblyCache" and add the full assembly details.
  • Re-work the solution for WSP Builder, remove the build script, and recreate the WSP.

I did the latter because I love WSP Builder! Deployed the WSP and all was good.